[R] Lattice: it seems, a bug in draw.key function

From: Wladimir Eremeev <wl_at_eimb.ru>
Date: Fri 20 May 2005 - 22:05:21 EST


Dear r-help,

  Now I am drawing graphs with xyplot function.   

  In order to place a legend under the plots I use the key argument in the xyplot function.

  One of the 'key' components is 'divide', which defines a number of   points on the each line of the legend. The default is 3 points.   I would like a single point, so I set divide = 1.

  Call to xyplot didn't produce any points at all.

  The body of draw.key function contains the following   

pointsGrob(x=(1:key$divide-1)/(key$divide-1), y=rep(0.5,key$divide),

            [skip]
          )
          

When key$divide=1, x is NaN...

--
Best regards
Wladimir Eremeev                                     mailto:wl@eimb.ru

==========================================================================
Research Scientist, PhD                           Leninsky Prospect 33,
Space Monitoring & Ecoinformation Systems Sector, Moscow, Russia, 119071,
Institute of Ecology,                             Phone: (095) 135-9972;
Russian Academy of Sciences                       Fax: (095) 135-9972

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Fri May 20 22:18:38 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:31:56 EST