Re: [R] lme4 package and importIntoEnv errors

From: Patrick Connolly <p.connolly_at_hortresearch.co.nz>
Date: Wed 25 May 2005 - 06:51:13 EST

On Tue, 24-May-2005 at 08:40AM -0500, Douglas Bates wrote:  

|> Perhaps I can add a bit more explanation. As Deepayan mentioned, the
|> versions of the lme4 package are closely linked to the versions of the
|> Matrix package. The R code for lmer is in the lme4 package but the
|> corresponding C code is in the Matrix package where it can gain access
|> to other C functions for sparse matrix manipulation.

Thanks for that explanation. I was curious to know why it's so different from other packages I've had no trouble with.

My problem did, indeed, arise from using an older version of lme4 with a new version of Matrix. Douglas's post explains why lme4_0.95-8.tar.gz is so much smaller than lme4_0.8-2.tar.gz. I feel much less confused now.

Thank you Renaud Lancelot and Deepayan Sarkar also.

-- 
Patrick Connolly
HortResearch
Mt Albert
Auckland
New Zealand 
Ph: +64-9 815 4200 x 7188
~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~
I have the world`s largest collection of seashells. I keep it on all
the beaches of the world ... Perhaps you`ve seen it.  ---Steven Wright 
~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Wed May 25 07:05:41 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:32:01 EST