Re: [R] jpeg function problem with rterm.exe

From: Uwe Ligges <ligges_at_statistik.uni-dortmund.de>
Date: Wed 01 Jun 2005 - 01:10:05 EST

Audouy Jerome (ext_sub) wrote:

> Hello,
>
> I'm starting using R and runned a little script. The generated graphic could be exported correctly with RGui.exe ("file -> save as -> jpeg -> etc.")
>
> But if I try to run the same script with Rterm.exe and followed by:
> jpeg(file="test.jpeg", quality=90)
> The created jpeg file is completely white without any color, do you know why ?
>
> Sum up of the script:
> library(DBI)
> library(RODBC)
> library(graphics)
> # my script process
> ...
> ...
> # save picture
> jpeg(file="test.jpeg", quality=90)

Please read An Introduction to R.
Please read ?Devices
Please read ?jpeg and see its examples!

jpeg() is not intended to save a plot, but to open a jpeg device you can plot into and close it afterwards:

   jpeg(file="test.jpeg", quality=90)
   plot(1:10)
   dev.off()

Please try it interaktively at first.

Uwe Ligges

>
> Thanks to help me.
>
> Regards,
> Jérôme.
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Wed Jun 01 01:13:29 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:32:17 EST