Re: [R] Strange characters in 2.1.0?

From: Martin Maechler <maechler_at_stat.math.ethz.ch>
Date: Wed 08 Jun 2005 - 00:10:18 EST

>>>>> "Dan" == Dan Bolser <dmb@mrc-dunn.cam.ac.uk> >>>>> on Mon, 6 Jun 2005 14:48:50 +0100 (BST) writes:

    Dan> On Mon, 6 Jun 2005, Douglas Bates wrote:

    >> On 6/6/05, Dan Bolser <dmb@mrc-dunn.cam.ac.uk> wrote:

>>>
>>> Signif. codes: 0 *** 0.001 ** 0.01 * 0.05 . 0.1 1
>>>
>>> Signif. codes: 0 <80><98>***<80><99> 0.001 <80><98>**<80><99> 0.01
>>> <80><98>*<80> <99> 0.05 <80><98>.<80><99> 0.1 <80><98> <80><99> 1
>>>
>>> Signif. codes: 0 *** 0.001 ** 0.01 * 0.05 . 0.1 1
>>>
>>> hmm... they go away when I paste them in...
    >> 
    >> Check the character set in use.  You probably are using a UTF-8
    >> encoding in an environment that does not support display of that
    >> character set.

    Dan> I feel it is something utf8-ish, I am using emacs-ess-5.2.3, which was     Dan> working fine under R-2.0.0, but developed this problem under R-2.1.0

ess-5.2.3 is outdated for the purpose of well cooperating with UTF-8 outputs from R 2.1.x
IIRC, ESS cooperates with R "with UTF encoding" since about ESS 5.2.6. but ESS-5.2.8 is current { --> http://ESS.r-project.org/ )

      ..........

    Dan> I have gone back to 2.0.0 :)

Don't do that!
You've lost tons of nice new features and gained quite an amount of old bugs by downgrading ..

Martin



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Wed Jun 08 00:43:32 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:32:27 EST