Re: [R] RGui crashes on wle call

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Tue 14 Jun 2005 - 16:23:03 EST

On Mon, 13 Jun 2005, Chris Bergstresser wrote:

> Hi all --
>
> I'm seeing the following commands reliably produce a crash in RGui,
> version 2.0.1, for both my home and office machine:
>
> > rm(list = ls(all = TRUE));
> > load("dataset.R");
> > library("wle");
> > data.wle = wle.lm(abortion ~ year * lib.con + age + gender +
> + urbanism + census + income + church.att + children + educ +
> + religion.imp, data = data.set);
>
> dataset.R is moderately sized (about 200k compressed), and the
> command works just fine with "lm" rather than "wle.lm". Since I'm not
> sure where the bug lies -- in wle, in R, or in RGui -- I'm not sure
> where I should report this, or if it's already been reported.
> What should I do?

There is good advice in the posting guide. Following that

  1. Re-do the tests in the current version of R, preferably a beta of 2.1.1.
  2. Read the rw-FAQ, do the debugging reported there (with Dr MinGW or gdb) and find where it is crashing. (This is very likely to be in wle.) If it is in wle, send a report to the maintainer. If it is in R, send a report to R-bugs. In either case, supply enough data to reproduce the problem.
-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Tue Jun 14 16:27:33 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:32:33 EST