Re: [R] Trying to build R sources on Windows

From: Duncan Murdoch <murdoch_at_stats.uwo.ca>
Date: Sun 19 Jun 2005 - 11:31:58 EST

Bill Northcott wrote:
> On 18/06/2005, at 10:34 PM, Uwe Ligges wrote:
>

>>>I am trying without success to build the R-2.1.0 sources on  
>>>Windows  2003 server.
>>>I have MinGW/bin in front of cygwin/bin in the Windows path.

>
>
>>I don't think it is a good idea to leave cygwin in your path for  
>>compiling R, even using it prior to the build process might be  
>>dangerous, because you might use another version of cygwin(1).dll  
>>than the one in the tools collection etc.
>>
>>Just set your path again without having cygwin in it..., this  
>>should be sufficient if you have all other relevant tools installed  
>>and in your path.

>
>
> Thanks for the thoughts. I have now got past this road block, and
> have almost managed to build everything. Along the way, it is clear
> there are some glaring omissions/misleading statements in the current
> documentation.
>
> When I have it all working, I will write it up on R-devel and perhaps
> some one could update the documentation.
>
> Bill Northcott
>
> PS The immediate cause of the header file problems was src/gnuwin32/
> fixed/h/config.h. This needs to be regenerated for every build
> configuration. This is not documented except obliquely in src/
> gnuwin32/Maintainer.notes

Are you running configure? Why?

Duncan Murdoch



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sun Jun 19 11:51:33 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:32:51 EST