Re: [R] Trouble with Excel table connection

From: Steve Sherman <ssherman_at_cemml.colostate.edu>
Date: Fri 01 Jul 2005 - 06:31:31 EST

That's the conclusion that I've come to. It was working fine, then it wasn't.

I know I was using the same commands because I wrote them into a small script.

I'll just import it into Access and stop pulling my hair out over this.

Thanks.

bogdan romocea wrote:

>The best 3 things you can do in this situation are:
>1. don't use Excel.
>2. never use Excel.
>3. never ever use Excel again.
>
>Spreadsheets are _not_ databases. In particular, Excel is a time bomb
>- use it long enough and you'll get burned (perhaps without even
>realizing it). See
>http://www.burns-stat.com/pages/Tutor/spreadsheet_addiction.html for
>some details.
>
>hth,
>b.
>
>
>
>
>>-----Original Message-----
>>From: Steve Sherman [mailto:ssherman@cemml.colostate.edu]
>>Sent: Thursday, June 30, 2005 2:46 PM
>>To: r-help@stat.math.ethz.ch
>>Subject: [R] Trouble with Excel table connection
>>
>>
>>Hello,
>>
>>I've been using odbcConnectExcel to connect to a spreadsheet database
>>containing a single worksheet. Unfortunately when I try to access the
>>data R cannot see the table. When I run sqlTables it shows
>>the worksheet
>>as a SYSTEM TABLE instead of as a TABLE that I can access. I
>>am fairly
>>certain that I am do all of the same things I've done in the
>>past when
>>it worked just fine. What might I be doing wrong?
>>
>>btw: it works just fine with MS Access, but I'd prefer to
>>work directly
>>from my Excel spreadsheets.
>>
>>Thanks in advance
>>Steve
>>
>>______________________________________________
>>R-help@stat.math.ethz.ch mailing list
>>https://stat.ethz.ch/mailman/listinfo/r-help
>>PLEASE do read the posting guide!
>>http://www.R-project.org/posting-guide.html
>>
>>
>>
>
>
>



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Fri Jul 01 06:34:38 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:33:08 EST