[R] r version 2.1.0 and graphics in mac os 10.3.9

From: Luis Borda de Agua <lbagua_at_uga.edu>
Date: Tue 05 Jul 2005 - 04:42:48 EST


I use mac os 10.3.9 and I've installed in my computer R 2.1.0 (I believe this is the latest R version).

Although it works alright when I open R by clicking in the R icon, I cannot use the graphics facility when I open R from a X-terminal window
(or x-11 window).

In fact, when I try to open R I get the message that I pasted below. Is this a R bug?
Is R assuming that I should have the latest Mac OS Tiger installed? Or is it a problem related to my computer only?

I did not have this problem when I used a previous version of R (I don't know which one was).

Thank you in advance for your help.

Luis BA.


% R

R : Copyright 2005, The R Foundation for Statistical Computing Version 2.1.0 Patched (2005-05-12), ISBN 3-900051-07-0

R is free software and comes with ABSOLUTELY NO WARRANTY. You are welcome to redistribute it under certain conditions. Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors. Type 'contributors()' for more information and 'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or 'help.start()' for a HTML browser interface to help. Type 'q()' to quit R.

[Previously saved workspace restored]

Error in dyn.load(x, as.logical(local), as.logical(now)) :

         unable to load shared library '/Library/Frameworks/R.framework/Resources/library/grDevices/libs/ grDevices.so':

   dlcompat: dyld: /Library/Frameworks/R.framework/Resources/bin/exec/R version mismatch for library: /usr/local/lib/libxml2.2.dylib
(compatibility version of user: 9.0.0 greater than library's version:
8.0.0)
Loading required package: grDevices
Error in dyn.load(x, as.logical(local), as.logical(now)) :

         unable to load shared library '/Library/Frameworks/R.framework/Resources/library/grDevices/libs/ grDevices.so':

   dlcompat: dyld: /Library/Frameworks/R.framework/Resources/bin/exec/R version mismatch for library: /usr/local/lib/libxml2.2.dylib
(compatibility version of user: 9.0.0 greater than library's version:
8.0.0)
In addition: Warning message:
package grDevices in options("defaultPackages") was not found Error: package 'grDevices' could not be loaded



Luis Borda de Agua
2502 Department of Plant Biology
University of Georgia

Athens GA 30602
USA
Phone: (706) 583-0943
Fax: (706) 542-1805

R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Tue Jul 05 04:45:10 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:33:12 EST