Re: [R] package loading smooth.lf (LOCFIT), couldn't find function "smooth.lf"

From: Uwe Ligges <ligges_at_statistik.uni-dortmund.de>
Date: Sun 10 Jul 2005 - 20:19:00 EST

Y Y wrote:

> After loading locfit, I am unable to access functions within locfit.
>
> following
> http://www.herine.net/locfit/start.html
>
>

>>library("locfit")
>>x <- 10*runif(100)
>>y <- 5*sin(x)+rnorm(100)
>>fit <- smooth.lf(x,y)

>
> Error: couldn't find function "smooth.lf"

So it is time to ask the maintainers of the package and the cited URL (CCing both) to update at least one of them (package or http://www.herine.net/locfit/start.html)

While the web page states the last update is "(December 16, 2004 version)", the version on CRAN is locfit_1.1-9.tar.gz dated 14-Sep-2004.

Uwe Ligges

>
>

>>fit <- locfit(y~lp(x))

>
> Error in eval(expr, envir, enclos) : couldn't find function "lp"
>
> library() or package manager GUI tells me locfit is loaded
>
> Any ideas on how to fix this ?
>
> SS, running on R 2.1, MacOS 10.3.9
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html


R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sun Jul 10 20:19:59 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:33:27 EST