Re: [R] package (!) mclust in 64bit compiled R

From: Martin Maechler <maechler_at_stat.math.ethz.ch>
Date: Wed 20 Jul 2005 - 17:19:25 EST

>>>>> "TaeHC" == Tae-Hoon Chung <thchung@tgen.org> >>>>> on Tue, 19 Jul 2005 10:26:01 -0700 writes:

    TaeHC> Hi, All; I tried to use library mclust in 64-bit     TaeHC> compiled R 2.0.1 but failed.

you mean "package mclust"
{a package is installed in a library full of packages}

    TaeHC> Installation went smoothly without any warning or
    TaeHC> error. However, when I tried to use them with the
    TaeHC> following simple code, it crashed.


> library(mclust)
> Dat <- c(rnorm(20, mean=0, sd=0.2), rnorm(30, mean=1, sd=0.2))
> Ind <- Mclust(dat, 1, 5)$classification
> cbind(Dat, Ind)

My desktop has been a 64-bit (AMD Athlon 64) for more than a year now, and I do note small differences to 32-bit some times, and even have found (and not yet solved) quite severe problem with the akima package.

Not with 'mclust' though.
I've just run several 1000 of Mclust() fits like the one above and not seen any problem.

    TaeHC> The error message was:

    TaeHC> /usr/local/R-2.0.1_64bit/lib/R/bin/BATCH: line 55:
    TaeHC> 18097 Done ( echo "invisible(options(echo = TRUE))";
    TaeHC> cat ${in}; echo "proc.time()" ) 18099 Segmentation
    TaeHC> fault | ${R_HOME}/bin/R ${opts} >${out} 2>&1
	  

    TaeHC> Can anybody help me with this? Thanks in advance,

  R -d gdb
  r

  then the above R code,
  and then maybe type 'bt' (backtrace) ?

Regards,
Martin Maechler, ETH Zurich



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Wed Jul 20 17:36:36 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:33:51 EST