Re: [R] Cannot update some packages after upgrade to 2.1.1

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Thu 21 Jul 2005 - 00:04:35 EST

On Wed, 20 Jul 2005, Kevin E. Thorpe wrote:

> Thank you for the information. I have contacted the RPM maintainer and am
> awaiting a response.
>
> It occurs to me that my "problem" could also be fixed by putting ATLAS on my
> system. Are there advantages to doing that or any reasons not to?

It is a good idea unless you share R systems between different architectures (even down to the vintage of P4 or Xeon chips). We do and so tend to avoid ATLAS (which gets statically compiled in by default).

>
> Prof Brian Ripley wrote:
>
>> -lf77blas is part of ATLAS, so I do suspect the RPM builder had ATLAS
>> installed.
>>
>> lme4 needs a compatible Matrix installed.
>>
>> I do think installing from the sources would solve this, but probably you
>> need to discuss this with the RPM maintainer as a dependency appears to be
>> missing.
>>
>> On Fri, 15 Jul 2005, Kevin E. Thorpe wrote:
>>
>>> I just upgraded to version 2.1.1 (from 2.0.1) today.
>>>
>>> > R.version
>>> _
>>> platform i686-pc-linux-gnu
>>> arch i686
>>> os linux-gnu
>>> system i686, linux-gnu
>>> status
>>> major 2
>>> minor 1.1
>>> year 2005
>>> month 06
>>> day 20
>>> language R
>>>
>>> I am using SuSE 9.2 and did the upgrade using rpm -U with the RPM
>>> available on CRAN. After upgrading r-base, I ran update.packages().
>>> Four previously installed packages failed to update:
>>>
>>> Matrix (0.95-5 to 0.97-4)
>>> gam (0.93 to 0.94)
>>> lme4 (0.95-3 to 0.96-1)
>>> mgcv (1.3-1 to 1.3-4)
>>>
>>> In the case of Matrix, gam and mgcv I get the message:
>>>
>>> [long path]/ld: cannot find -lf77blas
>>>
>>> In the case of lme4 the messages are:
>>>
>>> ** preparing package for lazy loading
>>> Error in setMethod("coef", signature(object = "lmList"), function(object,
>>> :
>>> no existing definition for function 'coef'
>>> Error: unable to load R code in package 'lme4'
>>> Execution halted
>>> ERROR: lazy loading failed for package 'lme4'
>>>
>>> I have searched the SuSE repository for any package that provides
>>> f77blas but came up empty.
>>>
>>> I also could not identify any relevant messages in the mailing list
>>> archives.
>>>
>>> Is R looking for that library because it was present on the machine
>>> the RPM was built on? Would building R myself solve the missing library
>>> problem or did I do something wrong?
>>>
>
>
> --
> Kevin E. Thorpe
> Biostatistician/Trialist, Knowledge Translation Program
> Assistant Professor, Department of Public Health Sciences
> Faculty of Medicine, University of Toronto
> email: kevin.thorpe@utoronto.ca Tel: 416.946.8081 Fax: 416.971.2462
>
>

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Thu Jul 21 00:14:52 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:33:51 EST