Re: [R] debian vcd package

From: Jan T. Kim <jtk_at_cmp.uea.ac.uk>
Date: Fri 22 Jul 2005 - 01:45:12 EST

On Thu, Jul 21, 2005 at 03:55:29PM +0100, Peter Ho wrote:
> [Apologies if you have already read this message sent from another
> email address]
>
> Hi R-Help,
>
> I have been using R in Linux (Debian) for the past month. The usual way
> I install packages is through apt. Recently, a new packages "vcd" became
> available on CRAN. I tried installing it today and found that Debian
> does not seem to support this package. I also found that many other
> packages were unavailable.
> Does anyone have any recommended sites where a full list is available?
> If none exist, what would be the best way to move ahead in installing
> say the vcd package.
>
> I am still a novice in using Debian and so please forgive me if some of
> my questions may seem trivial for experienced users.

Unfortunately, the term "package" means different things in the context of R and of Debian. A Debian package is what you install using tools like apt etc. The traditional way of installing an R package on Linux is to

        R CMD INSTALL vcd_0.9-0.tar.gz

This requires having a number of development Debian packages installed, such as gcc, g77 etc (installing r-base-dev will automatically resolve such dependencies).

Best regards, Jan

-- 
 +- Jan T. Kim -------------------------------------------------------+
 |    *NEW*    email: jtk@cmp.uea.ac.uk                               |
 |    *NEW*    WWW:   http://www.cmp.uea.ac.uk/people/jtk             |
 *-----=<  hierarchical systems are for files, not for humans  >=-----*

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Fri Jul 22 02:19:14 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:33:55 EST