Re: [R] Cannot update some packages after upgrade to 2.1.1

From: Kevin E. Thorpe <kevin.thorpe_at_utoronto.ca>
Date: Fri 22 Jul 2005 - 23:58:09 EST

Prof Brian Ripley wrote:

> On Wed, 20 Jul 2005, Kevin E. Thorpe wrote:
>
>> Thank you for the information. I have contacted the RPM maintainer
>> and am awaiting a response.
>>
>> It occurs to me that my "problem" could also be fixed by putting
>> ATLAS on my system. Are there advantages to doing that or any reasons
>> not to?
>
>
> It is a good idea unless you share R systems between different
> architectures (even down to the vintage of P4 or Xeon chips). We do
> and so tend to avoid ATLAS (which gets statically compiled in by
> default).

After following the discussion between you and Uwe, and thinking a bit, I've decided to give it a try. My system is basically stand-alone so different architectures are not an issue.

Now my question (recognising this may be the wrong list). I successfully compiled ATLAS, but it isn't clear to me from the install instructions that came with it how to make the libraries "seen" by gcc and g77 and therefore, presumably by the configure script with the R source. How do I make the libraries available? I've looked at the ATLAS project page and done a couple RSiteSearch's but have not yet recognised the answer to my question.

>>
>> Prof Brian Ripley wrote:
>>
>>> -lf77blas is part of ATLAS, so I do suspect the RPM builder had
>>> ATLAS installed.
>>>
>>> lme4 needs a compatible Matrix installed.
>>>
>>> I do think installing from the sources would solve this, but
>>> probably you need to discuss this with the RPM maintainer as a
>>> dependency appears to be missing.
>>>
>>> On Fri, 15 Jul 2005, Kevin E. Thorpe wrote:
>>>
>>>> I just upgraded to version 2.1.1 (from 2.0.1) today.
>>>>
>>>> > R.version
>>>> _
>>>> platform i686-pc-linux-gnu
>>>> arch i686
>>>> os linux-gnu
>>>> system i686, linux-gnu
>>>> status
>>>> major 2
>>>> minor 1.1
>>>> year 2005
>>>> month 06
>>>> day 20
>>>> language R
>>>>
>>>> I am using SuSE 9.2 and did the upgrade using rpm -U with the RPM
>>>> available on CRAN. After upgrading r-base, I ran update.packages().
>>>> Four previously installed packages failed to update:
>>>>
>>>> Matrix (0.95-5 to 0.97-4)
>>>> gam (0.93 to 0.94)
>>>> lme4 (0.95-3 to 0.96-1)
>>>> mgcv (1.3-1 to 1.3-4)
>>>>
>>>> In the case of Matrix, gam and mgcv I get the message:
>>>>
>>>> [long path]/ld: cannot find -lf77blas
>>>>
>>>> In the case of lme4 the messages are:
>>>>
>>>> ** preparing package for lazy loading
>>>> Error in setMethod("coef", signature(object = "lmList"),
>>>> function(object, :
>>>> no existing definition for function 'coef'
>>>> Error: unable to load R code in package 'lme4'
>>>> Execution halted
>>>> ERROR: lazy loading failed for package 'lme4'
>>>>
>>>> I have searched the SuSE repository for any package that provides
>>>> f77blas but came up empty.
>>>>
>>>> I also could not identify any relevant messages in the mailing list
>>>> archives.
>>>>
>>>> Is R looking for that library because it was present on the machine
>>>> the RPM was built on? Would building R myself solve the missing
>>>> library
>>>> problem or did I do something wrong?
>>>>

-- 
Kevin E. Thorpe
Biostatistician/Trialist, Knowledge Translation Program
Assistant Professor, Department of Public Health Sciences
Faculty of Medicine, University of Toronto
email: kevin.thorpe@utoronto.ca  Tel: 416.946.8081  Fax: 416.971.2462

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Sat Jul 23 00:03:42 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:33:55 EST