Re: [R] missing sh.exe file when running "R CMD INSTALL test"

From: Uwe Ligges <ligges_at_statistik.uni-dortmund.de>
Date: Tue 16 Aug 2005 - 17:23:11 EST

Chin Chieh wrote:

> I am trying to learn how to make a simple package that contains no C
> or Fortran code. I used package.skeleton(...) to make a package
> called "test". The directory and files look good. I downloaded and
> installed Rtools (www.murdoch-sutherland.com/Rtools/tools.zip). I
> added the path and from the dos prompt I can verify that make.exe and
> sh.exe both exist, but when I try to run "R CMD INSTALL test" I get an
> error "make: sh.exe: Command not found" and "make: *** [pkg-test]
> Error 127". I get the same error message if a try the command "make
> pkg-test".

Are you sure it is really in the path of the shell from which you are executing R CMD?
I think this is not the case. Try typing sh.exe therein directly ...

Uwe Ligges

> I saw in an old FAQ a suggestion to move sh.eve to the C:\bin\ folder,
> but my C: root does not have a "bin" folder. Nonetheless, I created
> one and put sh.exe there and it provided no help (I didn't expect it
> too).
>
> Can anyone help me?
>
>
> [[alternative HTML version deleted]]
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Tue Aug 16 17:29:21 2005

This archive was generated by hypermail 2.1.8 : Sun 23 Oct 2005 - 15:22:12 EST