Re: [R] question sur R

From: Spencer Graves <spencer.graves_at_pdf.com>
Date: Tue 30 Aug 2005 - 13:51:09 EST

          My knowledge of French is not adequate to ensure that I understand your question, but since I haven't seen a reply to your post, I will attempt a few comments.

          Do you know the "X" matrix that generated the "Error in svd(X) : infinite or missing values in x"? If yes, have you tried to find missing or Inf values in X? If X is small, you could print it. Otherwise, you might try "which(is.na(X))" and "which(abs(X)==Inf)".

          If you don't know the "X" in the error message, I suggest two things:   First, have you tried "traceback()"? that may or may not help you. Second, I don't know what function you are using, but much of R is written in R. I have on many occasions listed a function, copied it into a script file and worked through it line by line until I find the problem.

          If you still have a question, feel free to try this list again. I have two suggestions that may increase the speed and utility of a response:

          (1) S'il vous plait, ecrire en le langue anglais. Les lectures comme moi ne tienes problems avec des fautes en l'utilization de la langue. Et bien, il y a beaucoup de personnes qui peut repondre a un question posee en anglais q'en francais.

          (2) PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html

	  Bon chance.
	  Spencer Graves

Abdelhafid BERRICHI wrote:

> bonjour
>
> je suis elève à l'ENSAI Rennes et je suis actuellement en stage de fin
> d'études
>
> j'ai une question sur R
>
> en fait lorsque le simule 2 lois normales qui sont mes 2 variables
> explicatives continus
> - une avec que des valeurs > 0 (ou que <0) X1
> - l'autre peut prendre aussi bien des valeurs <0 ou >0 X2
>
>
> et que je regresse le rating (facteur ordonné) sur X1 ca marche alors que
> sur X2 ca ne marche pas : il m'indique l'erreur suivante
>
> Re-fitting to get Hessian
> Error in svd(X) : infinite or missing
> values in x
>
>
> pourtant svd(X2) fonctionne bien : il fait bien la décomposition en
> valeurs singulière
>
> est-ce du au signe des valeurs ou bien est-ce un autre problème?
>
> merci d'avance!!
>
> cordialement
>
> abdelhafid berrichi
> [[alternative HTML version deleted]]
>
>
>
> ------------------------------------------------------------------------
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html

-- 
Spencer Graves, PhD
Senior Development Engineer
PDF Solutions, Inc.
333 West San Carlos Street Suite 700
San Jose, CA 95110, USA

spencer.graves@pdf.com
www.pdf.com <http://www.pdf.com>
Tel:  408-938-4420
Fax: 408-280-7915

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Tue Aug 30 14:03:10 2005

This archive was generated by hypermail 2.1.8 : Sun 23 Oct 2005 - 16:06:21 EST