Re: [R] gnomeGUI installation

From: Marc Schwartz (via MN) <mschwartz_at_mn.rr.com>
Date: Tue 04 Oct 2005 - 03:21:38 EST

On Mon, 2005-10-03 at 18:01 +0100, Prof Brian Ripley wrote:
> On Mon, 3 Oct 2005, Daniel Pick wrote:
>
> > I have successfully downloaded the sources and built R as a shared
> > library on a Red Hat Enterprise Level 3 box. I am now trying to build the
> > GNOME GUI, but configure is barfing on glade. According to the system
> > logs, the RPM for libglade2-devel-2.0.1-3.x86_64 is installed, but in
> > /usr/bin, where gnomeGUI configure is looking, what's there is
> > libglade-convert. How do I fix this?
>
> By reading the manual. In the R-admin manual it says
>
> `Please check you have all the requirements. You need at least the
> following packages or later installed:
>
> audiofile-0.2.1
> esound-0.2.23
> glib-1.2.10
> gtk+-1.2.10
> imlib-1.9.10
> ORBit-0.5.12
> gnome-libs-1.4.1.2
> libxml-1.8.16
> libglade-0.17
>
> ...
>
> Remember that some package management systems (such as @acronym{RPM} and
> deb) make a distinction between the user version of a package and the
> developer version. The latter usually has the same name but with the
> extension @samp{-devel} or @samp{-dev}. If you use a pre-packaged
> version of @acronym{GNOME} then you must have the developer versions of
> the above packages in order to compile the R-GNOME console.'
>
> My FC3 box has
>
> gannet% rpm -qa | grep ^libglade
> libglade2-devel-2.4.0-5
> libglade-devel-0.17-15
> libglade2-2.4.0-5
> libglade-0.17-15
>
> and note that libglade2[-devel] is NOT a later version of libglade (in the
> same way that gtk2 is different from gtk).
>
> AFAICS it is likely that /usr/bin/libglade-config is provided by
> libglade-devel-0.17-15.

That is correct, subject of course to RPM version differences between FC3/4 and RHEL3/4. Using RPM, this can be confirmed with:

$ rpm -q --whatprovides /usr/bin/libglade-config libglade-devel-0.17-16

which is the output on FC4.

HTH, Marc Schwartz



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Tue Oct 04 03:33:13 2005

This archive was generated by hypermail 2.1.8 : Sun 23 Oct 2005 - 18:15:35 EST