Re: [R] problem with installing a package

From: Claire Lee <jingli71_at_yahoo.com>
Date: Fri 07 Oct 2005 - 01:56:52 EST


I do have full access to that directory. I have the bbHist package in c:/PROGRA~1/R/rw2011/library/bbHist directory. Then under the library directory I did check and build. Here's what I got:

$ R CMD check bbHist
* checking for working latex ... OK

installing R.css in
c:/progra~1/r/rw2011/library/bbHist.Rcheck

Compiling
c:\progra~1\r\rw2011\library\bbHist\chm\bbHist.chm

Compile time: 0 minutes, 0 seconds

2       Topics
2       Local links
0       Internet links
1       Graphic


Created
c:\progra~1\r\rw2011\library\bbHist\chm\bbHist.chm, 21,741 bytes
Compression increased file by 9,099 bytes.   adding MD5 sums

$ R CMD build bbHist
* checking for file 'bbHist/DESCRIPTION' ... OK

And then when I do R CMD INSTALL bbHist, I get

open(c:/progra~1/r/rw2011/library/bbHist/DESCRIPTION): No such file or directory

The bbHist directory is removed and a 00LOCK directory is created. What I don't understand is if INSTALL removed the bbHist directory, why is it stilling looking for the DESCRIPTION file in that diretory? I'm really puzzled. If anyone has any idea, please let me know. Thanks.

> Date: Thu, 06 Oct 2005 08:47:23 +0200
> From: Uwe Ligges <ligges@statistik.uni-dortmund.de>
> Subject: Re: [R] problem in installing a package
> To: Claire Lee <jingli71@yahoo.com>
> Cc: r-help@stat.math.ethz.ch
> Message-ID:
> <4344C87B.3080107@statistik.uni-dortmund.de>
> Content-Type: text/plain; charset=us-ascii;
> format=flowed
> 
> Claire Lee wrote:
> 
> > I'm using R in Windows XP. I created a package
> myself.
> > I've used R CMD check to check it. Everything
> seems OK
> > except the latex. I get the error message:
> > * checking bbHist-manual.tex ... ERROR
> > LaTeX errors when creating DVI version.
> > This typically indicates Rd problems.
> > 
> > I ignored it because I didn't want to submit it to
> > CRAN.
> > 
> > Then I tried to use R CMD INSTALL to install it.
> First
> > I get: 
> > "mv: cannot move
> `c:/PROGRA~1/R/rw2011/library/bbHist'
> > to `c:/PROGRA~1/R/rw2011/library/00LOCK/bbHist
> > ': Permission denied" 
> >
> > and a bunch of making DLL errors.  Then when I
> tried a
> > second time, I get:
> > 
> >
>

open(c:/progra~1/r/rw2011/library/bbHist/DESCRIPTION):
> > No such file or directory
> > 
> > I can see a 00LOCK directory is created in the
> > c:/PROGRA~1/R/rw2011/library directory. Any idea
> why
> > this is happening?
> 
> No, information is still too sparse, unfortunately.
> Do you have full write access?
> The 00LOCK directory is used to save the older
> package in order to be 
> able to restore it if a new installtion fails.
> Something went wrong and you have to remove it
> manually now, I guess.
> 
> Uwe Ligges
> 
> 
> 
> 
> > Thanks.
> > 
> > Claire
> >

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Fri Oct 07 02:18:53 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:40:38 EST