Re: [R] R version 2.01.1, Crimson Editor and the "one" from nowhere

From: Philippe Grosjean <phgrosjean_at_sciviews.org>
Date: Sat 08 Oct 2005 - 19:42:36 EST

... OK, I have spot the problem: TpR.exe expects RGui running in English. Shortcut for the Windows menu is Alt-w, which is what it sends to R. Then, it sends "1", meaning, activate first window (the console). You have probably RGui running in French, or in another language. In French the menu is called "Fenętres", with the corresponding shortcut being Alt-n. Consequently, the menu is not triggered and the "1" is send to the command line.

Two solutions to continue using TpR.exe with R 2.1.1 or more: 1) Switch R in SDI mode,
2) Use RGui in MDI mode, but in English.

The third solution is to patch TpR.exe, which I will not do, because I need to program a separate command for each different language of R! Best,

Philippe Grosjean

..............................................<°}))><........
  ) ) ) ) )
( ( ( ( ( Prof. Philippe Grosjean

  ) ) ) ) )
( ( ( ( ( Numerical Ecology of Aquatic Systems
  ) ) ) ) ) Mons-Hainaut University, Pentagone (3D08)
( ( ( ( ( Academie Universitaire Wallonie-Bruxelles
  ) ) ) ) ) 8, av du Champ de Mars, 7000 Mons, Belgium
( ( ( ( (

  ) ) ) ) ) phone: + 32.65.37.34.97, fax: + 32.65.37.30.54
( ( ( ( ( email: Philippe.Grosjean@umh.ac.be
  ) ) ) ) )
( ( ( ( ( web: http://www.umh.ac.be/~econum
  ) ) ) ) ) http://www.sciviews.org
( ( ( ( (
..............................................................

Olivier ETERRADOSSI wrote:

> Dear List....
> sorry to bother you R-gurus with such an "unstatistical" question... but 
> I face a problem using Crimson Editor with R 2.01.1 that I never had 
> using R 2.00.1.
> I already posted on the Crimson Editor forum but it seems to be VERY few 
> R-users there....
> 
> I successfully used R v2.00.1until now (under Windows XP professionnal, 
> version 2002, Service Pack 2, P4 processor CPU 1.8 GHz), together with 
> Crimson Editor.
> This editor is "linked" to R using three files (TpR.exe, R.SPC and R.KEYS).
> I recently upgraded to R 2.01.1.
> I kept using my old TpR.exe, R.SPC and R.KEYS, because I did not find 
> any new files on the Crimson Editor "Release" web page.
> When I now launch a script, instead of getting my old, well known prompt :
>  > source("C:/Program Files/R/fooscript.txt")
> I get :
>  > 1source("C:/Program Files/R/fooscript.txt")
> with a "1" in front of the line.... and of course R  greets me with a 
> "syntax error" message.
> Then I have to remove the "1" by hand (pretty prehistoric, ...and does 
> not work if  my script is meant to launch other scripts during the 
> night....)
> I cannot figure where this "1" comes from !!
> Did some of you already encountered this problem, and how did you get 
> rid of it ?
> Thanks a lot, have a nice week-end. Olivier
>

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sat Oct 08 19:59:08 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:40:39 EST