Re: [R] how to control ticks in plots with yasp or xasp

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Sun 09 Oct 2005 - 03:21:50 EST

On Sat, 8 Oct 2005, Denis Chabot wrote:

> Hi, sorry about the bad syntax, though the right syntax would not have worked
> either, according to your tests (Mark, Brian, Peter).

It DOES work according to my tests! (Do give us the credit for testing our advice: we would appreciate your showing equal care.)

> Anyway it is too finicky, I will draw them myself. For instance,
>
> plot(1:100, xaxt="n")
> par(xaxp=c(0, 100, 10)) # the value is reset at each plot
> axis(1)
>
> Placed tick marks at intervals at 0, 10, ..., 100, as expected, but did not
> place a label under 100...

Does for me (2.2.0, Windows and X11 on Linux). Might the text be clipped on your unnamed device, so you need to set xpd? (If so, it will be clipped however you try to do this, and is an unrelated local problem.)

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Sun Oct 09 03:31:46 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:40:40 EST