Re: [R] R-2.2.0 compilation problem

From: Bill Northcott <w.northcott_at_unsw.edu.au>
Date: Sun 09 Oct 2005 - 15:45:04 EST

On 07/10/2005, at 8:00 PM, Robin Hankin wrote:
> I tried to compile R-2.2.0 just now. configure worked fine, but
> compilation stopped with

>
> ld: Undefined symbols:
> restFP
> saveFP
> /usr/bin/libtool: internal link edit command failed
> make[3]: *** [libR.dylib] Error 1
> make[2]: *** [R] Error 2
> make[1]: *** [R] Error 1
> make: *** [R] Error 1
> octopus:~/scratch/R-2.2.0%

This has been written up many times already. It would be nice if it was in the documentation.

g77 can only be used with gcc-3.x and earlier. The default compiler on Tiger is gcc-4.

All you need to do to build with g77 on Tiger is use the command sudo gcc_select 3.3
which will make gcc-3.3 the default compiler and it will all work.

Bill Northcott



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sun Oct 09 15:48:51 2005

This archive was generated by hypermail 2.1.8 : Sun 23 Oct 2005 - 18:33:02 EST