Re: [R] problem in installing a package

From: Ting-Yuan Liu <tliu_at_fhcrc.org>
Date: Wed 12 Oct 2005 - 17:57:57 EST

Hi Claire,

For the R CMD check error... It seems that you used some special characters, such as "_", in your Rd files so that Latex can not handle them. Try to add the escape charatcer "\" before these special characters.

HTH,
Ting-Yuan

On Wed, 5 Oct 2005, Claire Lee wrote:

> I'm using R in Windows XP. I created a package myself.
> I've used R CMD check to check it. Everything seems OK
> except the latex. I get the error message:
> * checking bbHist-manual.tex ... ERROR
> LaTeX errors when creating DVI version.
> This typically indicates Rd problems.
>
> I ignored it because I didn't want to submit it to
> CRAN.
>
> Then I tried to use R CMD INSTALL to install it. First
> I get:
> "mv: cannot move `c:/PROGRA~1/R/rw2011/library/bbHist'
> to `c:/PROGRA~1/R/rw2011/library/00LOCK/bbHist
> ': Permission denied"
>
> and a bunch of making DLL errors. Then when I tried a
> second time, I get:
>
> open(c:/progra~1/r/rw2011/library/bbHist/DESCRIPTION):
> No such file or directory
>
> I can see a 00LOCK directory is created in the
> c:/PROGRA~1/R/rw2011/library directory. Any idea why
> this is happening?
>
> Thanks.
>
> Claire
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
>



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Wed Oct 12 18:09:16 2005

This archive was generated by hypermail 2.1.8 : Sun 23 Oct 2005 - 18:47:08 EST