[R] How to install R 2.2.0 Debian 'unstable' package in otherwise 'sarge' system

From: Dan Davison <davison_at_uchicago.edu>
Date: Thu 13 Oct 2005 - 07:04:50 EST


I would like to install the latest version of R (the statistical computing software). This is package r-base version 2.2.0 and is in the debian 'unstable' repository. Otherwise my system has 'sarge' packages, including r-base 2.1.0. What is the best way to do this? If I don't want to upgrade to unstable, must I compile R myself, or is there some way to install this as a debian package?

I have tried:

(i) pointing /etc/apt/sources.list at unstable, apt-get updating and then
apt-get install r-base. This results in

[... full output at bottom of email ...]

E: This installation run will require temporarily removing the essential package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option. E: Internal Error, Could not early remove e2fsprogs

which scares me into desisting with this course of action.

(ii) apt-get install -t unstable r-base, but it replies that
r-base is already the newest version. Have I not invoked this command
correctly, or does the -t switch not do what I was thinking it did?

Thanks very much for any help,

Dan

dd:/home/dan# apt-get install r-base
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:

   e2fslibs e2fsprogs gcc-3.4-base libblkid1 libc6 libc6-dev libg2c0 libgcc1 libss2

   libuuid1 locales r-base-core r-base-dev r-recommended Suggested packages:

   gpart parted e2fsck-static glibc-doc ess libpaper-utils The following NEW packages will be installed:

   e2fslibs gcc-3.4-base libblkid1 libss2 libuuid1 The following packages will be upgraded:

   e2fsprogs libc6 libc6-dev libg2c0 libgcc1 locales r-base r-base-core r-base-dev

   r-recommended
10 upgraded, 5 newly installed, 0 to remove and 536 not upgraded. Need to get 0B/21.4MB of archives.
After unpacking 5886kB of additional disk space will be used. Do you want to continue? [Y/n] Y
E: This installation run will require temporarily removing the essential package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option.
E: Internal Error, Could not early remove e2fsprogs



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Thu Oct 13 07:16:27 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:40:42 EST