Re: [R] How to install R 2.2.0 Debian 'unstable' package in otherwise 'sarge' system

From: Dirk Eddelbuettel <edd_at_debian.org>
Date: Thu 13 Oct 2005 - 08:03:43 EST

Dan,

First off, there is even a r-sig-debian list in the universe of R mailing lists (c.f. the R FAQ). That probably provides a more focused readership than the union of r-help (where many won't know Debian) and debian-user (where many won't know R).

On Wed, Oct 12, 2005 at 04:04:50PM -0500, Dan Davison wrote:
> I would like to install the latest version of R (the statistical computing
> software). This is package r-base version 2.2.0 and is in the debian
> 'unstable' repository. Otherwise my system has 'sarge' packages, including
> r-base 2.1.0. What is the best way to do this?

Short answers:

i) In general, and especially between 'testing' and 'unstable', use apt-pinning, explained in the apt-howto packages, esp apt-howto-en for English; and on various places across the Net; try Google'ing for apt-pinning.

That way you get the option of installing selected parts of unstable without being forced to upgrade wholesale. Myself and countless other have used this for years between testing and unstable. However, I am not so sure how well it works between stable and unstable. It may work now as stable is fairly recent, but may fail further down the road.

ii) In this particular case, and as explained in the R FAQ, the CRAN archives have an apt-get'able section for Debian stable. However, Christian, the (CC'ed) maintainer of this backport was traveling between conferences in the US and has not yet provided R 2.2.0 (which was released less than a week ago, after all). It should appear shortly.

> to unstable, must I compile R myself, or is there some way to install this
> as a debian package?

You can also recompile locally using one of two ways:

iii) as a local Debian package, and apt-get source makes that almost automatic (provided you have source URIs in /etc/apt/sources.list, and that the Build-Depends are actually satisfiable under Debian stable), or

iv) as non-Debian compile into /usr/local

If you're in a hurry, iv) is your way. If you're intrigued by iii), try it. If you can wait a few days, ii) is probably your best bet.

> I have tried:
>
> (i) pointing /etc/apt/sources.list at unstable, apt-get updating and then
> apt-get install r-base. This results in
>
> [... full output at bottom of email ...]
>
> E: This installation run will require temporarily removing the essential
> package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad,
> but if you really want to do it, activate the APT::Force-LoopBreak option.
> E: Internal Error, Could not early remove e2fsprogs
>
> which scares me into desisting with this course of action.

I'd agree. Don't force things against warnings like this.

> (ii) apt-get install -t unstable r-base, but it replies that
> r-base is already the newest version. Have I not invoked this command
> correctly, or does the -t switch not do what I was thinking it did?

Did you run 'apt-get update' after altering /etc/apt/sources.list ?

Try 'apt-cache policy r-base-core' which will tell you about the versions it knows, where they are from, and how they are prioritized (aka "pinned").

> Thanks very much for any help,

Pleasure. Let me know in private mail if this is clear enough, and we could even follow up on a local phone call.

Greetings from across town to Hyde Park, Dirk

>
> Dan
>
>
> dd:/home/dan# apt-get install r-base
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following extra packages will be installed:
> e2fslibs e2fsprogs gcc-3.4-base libblkid1 libc6 libc6-dev libg2c0
> libgcc1 libss2
> libuuid1 locales r-base-core r-base-dev r-recommended
> Suggested packages:
> gpart parted e2fsck-static glibc-doc ess libpaper-utils
> The following NEW packages will be installed:
> e2fslibs gcc-3.4-base libblkid1 libss2 libuuid1
> The following packages will be upgraded:
> e2fsprogs libc6 libc6-dev libg2c0 libgcc1 locales r-base r-base-core
> r-base-dev
> r-recommended
> 10 upgraded, 5 newly installed, 0 to remove and 536 not upgraded.
> Need to get 0B/21.4MB of archives.
> After unpacking 5886kB of additional disk space will be used.
> Do you want to continue? [Y/n] Y
> E: This installation run will require temporarily removing the essential
> package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad,
> but if you really want to do it, activate the APT::Force-LoopBreak option.
> E: Internal Error, Could not early remove e2fsprogs
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html

-- 
Statistics: The (futile) attempt to offer certainty about uncertainty.
         -- Roger Koenker, 'Dictionary of Received Ideas of Statistics'

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Thu Oct 13 08:15:16 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:40:42 EST