Re: [R] write R extenesion issue

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Sun 16 Oct 2005 - 03:08:46 EST

Here is the cause:

>> * Installing *binary* package 'btRRTest' ...
                  ^^^^^^

However, you have a source package, and you have an invalid DESCRIPTION file containing a Built: line.

Please read `Writing R Extensions' and check you are following the rules it lays down (as in this respect at least you are not).

On Sat, 15 Oct 2005, jiesheng zhang wrote:

> I found my attachment was discarded.
> My R package structure lis listed here
> -----------------------------
> btRRTest
> DESCRIPTION
> Package: btRRTest
> Version: 0.0.1
> Date: 2005-10-15
> Title: a test remote R exeuction
> Author: jiesheng@bioteam.net
> Maintainer: jason zhang<jiesheng@bioteam.net>
> Depends: R (>= 1.8.0)
> Description: the remote execution of R call
> License: GPL version 2
> URL: http://www.bioteam.net
> Built: R 2.1.1; i686-pc-linux-gnu; 2005-09-20 00:07:19; unix
> Packaged: Sat Oct 15 23:42:11 2005; root
> INDEX
> btRRTestOut serialize all
> btRRTestInt unserialize all and execute
> R/btRRTest.R
> .First.lib <- function (lib, pkg)
> {
> #library.dynam("btRRTest", pkg, lib)
> print(c("first.lib", pkg, lib))
> }

>

> btRRTestOut<-function(x)
> {
> #.Call("btRRTestOut", substitute(x), rho=sys.frame(-1),
> PACKAGE="btRRTest");
> print("btRRTestOut");
> }
>
> btRRTestIn<-function()
> {
> #.Call("btRRTestIn", PACKAGE="btRRTest");
> print("btRRTestIn");
> }
>
> ----------------------------
>

> -jason
>
>

> jiesheng zhang wrote:
>> My package structure is very simple.
>> I attached it here.
>> Any help is appreciated.
>> -ason
>>
>> jiesheng zhang wrote:
>>> Hi, all
>>> I am trying to write a R package. I was able to build and install the
>>> package with no problem.
>>> However, I got this error when I try to load the library by calling
>>> library("btRRTest");
>>> ------------------error message in loading---------
>>> > library("btRRTest")
>>> Error in library("btRRTest") : 'btRRTest' is not a valid package --
>>> installed < 2.0.0?
>>> ---------------------------------
>>> --------build message-----------
>>> ason@jasonportal:~/tmp2> R CMD build --force btRRTest
>>> * checking for file 'btRRTest/DESCRIPTION' ... OK
>>> * preparing 'btRRTest':
>>> * checking DESCRIPTION meta-information ... OK
>>> * cleaning src
>>> * checking whether 'INDEX' is up-to-date ... NO
>>> * overwriting 'INDEX' as '--force' was given
>>> * removing junk files
>>> * checking for LF line-endings in source files
>>> * checking for empty directories
>>> * building 'btRRTest_0.0.1.tar.gz'
>>> ---------------------------------
>>> -------install message-------
>>> jasonportal:/home/jason/tmp2 # R CMD INSTALL btRRTest_0.0.1.tar.gz
>>> * Installing *binary* package 'btRRTest' ...
>>> * DONE (btRRTest)
>>> ----------------------
>>>
>>>
>>> Can anyone tell me what are the possible causes for this error? Where
>>> should I start to look?


-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sun Oct 16 03:21:44 2005

This archive was generated by hypermail 2.1.8 : Sun 23 Oct 2005 - 18:55:53 EST