Re: [R] loading packages - mac user

From: Cormac Lawler <cormaggio_at_gmail.com>
Date: Wed 19 Oct 2005 - 05:35:39 EST

In the Mac version, there is no Packages>Load Packages as there is in the PC version - instead there is the Package manager, which rejects my attempts to download Rcmdr (it loads other packages ok, like boot, graphics etc.) That was the error message I pasted at the end of my mail - this makes me think that there is possibly some interference with what I've already downloaded(?). Trying to work from the main console, but I can't find a comprehensive, easy to understand list of commands..
Cormac

On 10/18/05, Berton Gunter <gunter.berton@gene.com> wrote:
> You need to load it into R, I think. ?load -- or probably there is a menu
> item in the interface under "Packages" (there is in the Windows version,
> anyway).
>
> -- Bert Gunter
> Genentech Non-Clinical Statistics
> South San Francisco, CA
>
> "The business of the statistician is to catalyze the scientific learning
> process." - George E. P. Box
>
>
>
> > -----Original Message-----
> > From: r-help-bounces@stat.math.ethz.ch
> > [mailto:r-help-bounces@stat.math.ethz.ch] On Behalf Of Cormac Lawler
> > Sent: Tuesday, October 18, 2005 11:46 AM
> > To: r-help@stat.math.ethz.ch
> > Subject: [R] loading packages - mac user
> >
> > Hi,
> > I'm using a Mac, I've downloaded R (base), and I'm trying to download
> > the package R Commander. I thought I had already done this (both from
> > the web and from within R) but it doesn't seem to be working - it's
> > not there as a "search()" reveals. However, there are plenty of files

> > on my system linked with Rcmdr - located in
> > HD>Library>Frameworks>R.framework>Versions>2.1.1>Resources>Lib
> > rary>Rcmdr.
> > Is it simply in the wrong location to use it? The other possibility is
> > that I keep getting a tcltk error whenever I try to load up the
> > package from the Package Manager from within R - and when I try to
> > upload the tcltk package, this also gives the same error [1]. I also
> > get a "Couldn't launch application" error whenever I try to launch the
> > X11.app.

> >
> > This is probably so basic it's staring me in the eyes, but I need your
> > help please. I'd be happy to give any extra info you need.
> >
> > Thanks
> > Cormac
> >
> > [1] Loading required package: tcltk
> > Loading Tcl/Tk interface ... Error in dyn.load(x, as.logical(local),
> > as.logical(now)) :
> > unable to load shared library
> > '/Library/Frameworks/R.framework/Resources/library/tcltk/libs/
> > tcltk.so':
> > dlcompat: dyld: /Applications/R.app/Contents/MacOS/R can't open
> > library: /usr/local/lib/libtk8.4.dylib (No such file or directory,
> > errno = 2)
> > In addition: Warning messages:
> > 1: cannot create HTML package index in: make.packages.html()
> > 2: cannot create HTML package index in: make.packages.html()
> > Error: .onLoad failed in 'loadNamespace' for 'tcltk'
> > Error: package 'tcltk' could not be loaded
> >
> > ______________________________________________
> > R-help@stat.math.ethz.ch mailing list
> >
https://stat.ethz.ch/mailman/listinfo/r-help
> > PLEASE do read the posting guide!
> > http://www.R-project.org/posting-guide.html
> >
>
>
>



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Wed Oct 19 05:40:24 2005

This archive was generated by hypermail 2.1.8 : Sun 23 Oct 2005 - 19:03:06 EST