[R] installing Rmpi

From: Jon Savian <worknit_at_gmail.com>
Date: Fri 28 Oct 2005 - 07:17:56 EST

not sure if this message sent the first time, sorry :)

Hello,

I've installed R on my RHEL3 cluster and I am trying to get Rmpi to work properly.

R is installed using the following
./configure --prefix=/home/apps/R-2.2.0

I installed snow using
R CMD INSTALL /home/apps/snow

And finaly Rmpi
R CMD INSTALL /home/apps/Rmpi --configure-args=--with-mpi=/path/to/lam

There were no errors or warnings upon installation. However when i perform the test below i get an error message

R> library(snow)
R> cl <- makeCluster(2)

Rmpi version: 0.4-9

        Rmpi is an interface (wrapper) to MPI APIs
        with interactive R slave functionalities.
        See `library (help=Rmpi)' for details.
Error in dyn.load(x, as.logical(local), as.logical(now)) :
        unable to load shared library

'/home/apps/R-2.2.0/lib/R/library/Rmpi/libs/Rmpi.so':
  libmpi.so.0: cannot open shared object file: No such file or directory Error in dyn.unload(x) : dynamic/shared library
'/home/apps/R-2.2.0/lib/R/library/Rmpi/libs/Rmpi.so' was not loaded
Error in makeMPIcluster(spec, ...) : the `Rmpi' package is needed for MPI clusters.

The Rmpi.so exists and the permissions are fine. I also did a lamboot, and its running in the backround fine as well. Any suggestions?

Thanks.



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Fri Oct 28 07:47:01 2005

This archive was generated by hypermail 2.1.8 : Fri 28 Oct 2005 - 09:48:26 EST