Re: [R] library(its) problem

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Thu 01 Dec 2005 - 18:20:49 EST

On Wed, 30 Nov 2005, Erin Hodgess wrote:

> Dear R People:
>
> I wanted to use the package "its" this afternoon.
>
> I'm using R Version 2.2.0 for Windows.
>
> I was able to install the package, but ran into trouble at
> the "library" command. Here is the output:
>
>> library(its)
> Loading required package: Hmisc
> Hmisc library by Frank E Harrell Jr
>
> Type library(help='Hmisc'), ?Overview, or ?Hmisc.Overview')
> to see overall documentation.
>
> NOTE:Hmisc no longer redefines [.factor to drop unused levels when
> subsetting. To get the old behavior of Hmisc type dropUnusedLevels().
>
> Attaching package: 'Hmisc'
>
>
> The following object(s) are masked from package:stats :
>
> ecdf
>
> Error in lazyLoadDBfetch(key, datafile, compressed, envhook) :
> ReadItem: unknown type 241
> In addition: Warning message:
> package 'its' was built under R version 2.3.0
> Error: package/namespace load failed for 'its'
>
> Is there a new version 2.3.0, please>

Not yet: it means R-devel.

Where did you get the packages from? We've seen this sort of confusion (packages for R-devel under 2.2.x) on the statlib mirror, and suggest you re-install them from a different mirror.

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Thu Dec 01 18:31:36 2005

This archive was generated by hypermail 2.1.8 : Thu 01 Dec 2005 - 20:23:45 EST