[R] installation question/problem

From: DW <dwinner-lists_at_att.net>
Date: Sat 07 Jan 2006 - 04:45:00 EST


Hello,

Can anybody tell me why I am getting the error below when I run "make check" and if it has any consequences I may regret later?

I run:

#  ./configure --enable-R-shlib
# make
# make check
# make install


configure, make and make install all work without errors, and it seems to install ok, and I even test the R binary after install, so I guess it's working. But I want to make sure. I'm not going to be using R, but I'm the net admin who has been tasked with installing it our servers, so I don't want any nasty surprises.

I wonder if it's possible that I'm missing libraries because I'm not running X on the servers?

This is:
FreeBSD 5.4 p8
R-2.2.1

make check output:

(snip)
.....
running code in 'grDevices-Ex.R' ... OK
comparing 'grDevices-Ex.Rout' to 'grDevices-Ex.Rout.prev' ... OK
running code in 'graphics-Ex.R' ... OK
comparing 'graphics-Ex.Rout' to 'graphics-Ex.Rout.prev' ... OK running code in 'stats-Ex.R' ...*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1/tests/Examples.
*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1/tests/Examples.
*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1/tests.
*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1/tests.
*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1.

Thanks for any info,
DW



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sat Jan 07 04:50:46 2006

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:41:54 EST