[R] Latest revision of lme4 requires 'Matrix' >= 0.995.2 but that version is not available on CRAN

From: Søren Højsgaard <Soren.Hojsgaard_at_agrsci.dk>
Date: Sat 21 Jan 2006 - 22:15:12 EST


I just updated the packages on my pc (windows xp). When loading lme4 I get  

> library(lme4)

Error: package 'Matrix' 0.995-1 was found, but >= 0.995.2 is required by 'lme4'

'Matrix' 0.995-1 is indeed installed on my computer, but update.packages() does not capture a never version; and seemingly for good reasons: When looking at CRAN, the new version of Matrix is available - but only as a .tar.gz archive. Two questions  

  1. How can a new version of lme4 make its way to CRAN when the packages it depends on are not available (that is, in a zip-version)?

An answer could be: Buhh, you can just download the .tar.gz archive and then compile it yourself! Surely, that would be possible, but it can not be the intention...  

2) When actually trying to compile Matrix, I get  

lmer.o(.text+0x285f):lmer.c: undefined reference to `atanh'

make[3]: *** [Matrix.dll] Error 1
make[2]: *** [srcDynlib] Error 2
make[1]: *** [all] Error 2

make: *** [pkg-Matrix] Error 2
*** Installation of Matrix failed ***
Removing 'c:/programs/R/current/library/Matrix'
Restoring previous 'c:/programs/R/current/library/Matrix'  

Can anyone help me on what to do???
Thanks / Søren



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sat Jan 21 22:25:03 2006

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:42:08 EST