Re: [R] Latest revision of lme4 requires 'Matrix' >= 0.995.2 but that version is not available on CRAN

From: Søren Højsgaard <Soren.Hojsgaard_at_agrsci.dk>
Date: Sun 22 Jan 2006 - 02:16:11 EST

We (Doug, Martin and I) are trying hard to debug an error in Matrix. Martin and Doug have ideas for a bugfix and I am checking right now.

The latest version of Matrix that passed the checks was Matrix_0.995-1 which is still available from
http://cran.r-project.org/bin/windows/contrib/2.2/last/

The error was also present in Matrix_0.995-1, but in that case (and by chance) it did not cause a crash during the examples or tests (what happens for Matrix_0.995-2 under Windows).

Uwe Ligges


Dear Uwe,

Thats fine, but what puzzles me is that a new lme4-version can go on CRAN when it can not run under windows... ?

Anyway, that sort of things happen... I've now downloaded the previous version of lme4 as a tar.gz file - and that works. I wonder if it would be an idea to have a function rollback('pkg-name') for that sort of situations???

Best regards

Søren Højsgaard    

Moreover, now that I have updated to the latest release of lme4, I wonder how to get get a version of lme4 that actually works with the version of Matrix which is currently available.



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sun Jan 22 02:24:26 2006

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:42:09 EST