[R] Sweave: trouble controlling Design package startup output

From: Paul Johnson <pauljohn32_at_gmail.com>
Date: Tue 31 Jan 2006 - 10:37:19 EST


Hello, everybody:

I'm experimenting more with Sweave, R, and LyX. There's now an entry in the LyX wiki on using R, so anybody can do it!

http://wiki.lyx.org/LyX/LyxWithRThroughSweave

Now I notice this frustrating thing. I think I've done everything possible to make the Design library start up without any fanfare:

<<echo=F,quiet=T,print=F>>=
library(Design, verbose=F)
@

But in the output there is still one page of banner information, which starts like this:

Loading required package: Hmisc
Hmisc library by Frank E Harrell Jr
Type library(help= Hmisc ), ?Overview, or ?Hmisc.Overview ) to see overall documentation.
NOTE:Hmisc no longer redefines [.factor to drop unused levels when subsetting. To get the old behavior of Hmisc type dropUnusedLevels().   Attaching package: Hmisc The following object(s) are masked from package:stats :
[and so forth]

Can you tell me how to make it stop?

I've seen this kind of output with a couple of other packages over the past 2 months, but I can't find the files that produced them, so I can't cite the examples. But I don't think it is confined to Design.

--
Paul E. Johnson
Professor, Political Science
1541 Lilac Lane, Room 504
University of Kansas

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Tue Jan 31 10:45:31 2006

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:42:15 EST