Re: [R] Windows GUI package install annoyance

From: Uwe Ligges <ligges_at_statistik.uni-dortmund.de>
Date: Tue 14 Feb 2006 - 04:27:45 EST

Berton Gunter wrote:

> Folks:
>
> A minor (R 2.2.0) Windows package install annoyance, but I can't figure out
> how to fix it. If someone could tell me how or point me to the appropriate
> docs, I would appreciate it.
>
> I set my CRAN mirror in my Rprofile.site file. After startup, I get:
>
>

>>getOption('repos')

>
> CRAN
> "http:/cran.cnr.berkeley.edu/"
>
>
> However, when I then go to the GUI "Packages" menu item and click on
> "Install packages..." I get:
>
>
>>utils:::menuInstallPkgs()

>
> Warning: unable to access index for repository
> http:/cran.cnr.berkeley.edu/bin/windows/contrib/2.2
> Error in install.packages(NULL, .libPaths()[1], dependencies = TRUE, type =
> type) :
> no packages were specified
>
>
> However, If I now manually set my mirror (through the menu: "Set Cran
> mirror" item, which invokes chooseCRANmirror()) , and now check my repos
> option, I get again:
>
>
>>getOption('repos')

>
> CRAN
> "http://cran.cnr.Berkeley.edu"
>
>
> ## but now the "install packages.." menu choice works!
> Is there an easy way to avoid having to manually re-specify my CRAN mirror?

Yes: do not omit the second "/" after "http:" in "http://cran.cnr.berkeley.edu/" .....

Uwe Ligges

> My apologies for wasted bandwidth if I have overlooked something obvious,
> which I believe is the case.
>
> Many thanks.
>
> -- Bert
>
> Bert Gunter
> Genentech
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Tue Feb 14 04:39:31 2006

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:42:29 EST