Re: [R] Failure when updating package nlme

From: Uwe Ligges <ligges_at_statistik.uni-dortmund.de>
Date: Thu 16 Feb 2006 - 20:33:17 EST

CG Pettersson wrote:

> Hello all,
>
> R2.2.1, W2k
>
> I posted a similar question last week after having problem with a group
> update (using update.packages()), without getting any answer.
>
> Now I have updated all packages separately, and found that the problem
> comes from nlme:
>
> Everything comes home, the md5 checksums are ok, but then the old version
> can´t be removed from my computer, leaving a "nlme" library with only the
> "libs" sublibrary left.
>
> As my R doesn´t start without nlme, I am stuck here. R doesn´t start with
> only the "libs" left and doesn´t start without nlme. What´s going on?
>
> It´s no big crisis as I have the nlme version from the R installation
> file, but I try to keep my installation as updated as possible, so it´s
> irritating. :)

You cannot update a package if it is loaded, because Windows locks the dll. Hence start R without loading nlme (that it is loaded might be because you mentioned it in some Startup file such as .Rprofile or a saved Workspace image loads the package for some reason - don't know whether this could happen for nlme).
Hence RGui --vanilla might be right for you. Then update.packages().

Uwe Ligges

> /CG
>
>



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Thu Feb 16 20:49:16 2006

This archive was generated by hypermail 2.1.8 : Mon 20 Feb 2006 - 14:08:29 EST