Re: [R] new package error message

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Wed 10 May 2006 - 16:57:14 EST

On Tue, 9 May 2006, Jason Liao wrote:

> My coauthor made a new R package GeneLogit (100% R code) which installs
> ok on R 2.3 on Windows. But when I type
>
> library(GeneLogit)
>
> it gave the error message
>
> Error in library(GeneLogit) : 'GeneLogit' is not a valid package --
> installed < 2.0.0?
>
> It runs on R 1.9.0 just fine. It seems that others have encountered
> same problem but no solution is found by googling

In every case I have ever seen mentioned, the solution was to install the package properly by R CMD INSTALL and not by a manual kludge.

The message is given if the installation lacks the metadata in the Meta subdirectory which INSTALL creates.

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Wed May 10 17:00:06 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Thu 11 May 2006 - 02:10:07 EST.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.