Re: [R] Stuck in R installation, help~~

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Thu 18 May 2006 - 16:33:13 EST

This is covered in the R-admin manual:

   Note that the BLAS library will be used for several add-on packages as    well as for @R{} itself. This means that it is better to use a    shared/dynamic BLAS library, as most of a static library will be    compiled into the @R{} executable and each BLAS-using package. In any    case, the BLAS library must be usable with dynamically-loadable code:    this can be a problem with ATLAS on some platforms (including    @cputype{x86_64}) as it is not by default built with    position-independent code.

and the message was quite explicit that the problem was in -lf77blas, which is part of ATLAS. If you are not able to correct the problem with your ATLAS build, try configuring with --without-blas.

The INSTALL file points you to the R-admin manual, and since it contains the answers to your first two sticky points the chances are good it will help you with any further ones.

On Wed, 17 May 2006, Selina wrote:

> Hi all,
>
> I'm stuck in the installation of R.
> When I run configure, I got the error:
> configure: error: --with-readline=yes (default) and headers/libs are
> not available
>
> I followed one answer in some post and use this:

That is also explicitly in the R-admin manual.

> ./configure --with-prefix=/home/user/R-2.2.1 --with-readline=no
>
> It successfully configured but I encountered another problem while make:
>
> gcc -shared -L/usr/local/lib64 -o libRlapack.so dlamc.lo dlapack0.lo
> dlapack1.lo dlapack2.lo dlapack3.lo cmplx.lo -lf77blas -latlas -lg2c
> -lm -lgcc_s
> /usr/bin/ld:
> /usr/lib/gcc/x86_64-redhat-linux/3.4.4/../../../../lib64/libf77blas.a(xerbla.o):
> relocation R_X86_64_32 against `a local symbol' can not be used when
> making a shared object; recompile with -fPIC
> /usr/lib/gcc/x86_64-redhat-linux/3.4.4/../../../../lib64/libf77blas.a:
> could not read symbols: Bad value
> collect2: ld returned 1 exit status
> make[4]: *** [libRlapack.so] Error 1
> make[4]: Leaving directory `/home/user/R-2.2.1/src/modules/lapack'
> make[3]: *** [R] Error 2
> make[3]: Leaving directory `/home/user/R-2.2.1/src/modules/lapack'
> make[2]: *** [R] Error 1
> make[2]: Leaving directory `/home/user/R-2.2.1/src/modules'
> make[1]: *** [R] Error 1
> make[1]: Leaving directory `/home/user/R-2.2.1/src'
> make: *** [R] Error 1
>
> I just have no clue. I've been trying to fix this for a really long
> time. Any help or suggestion is highly appreciated!
>
> Thanks
>
> Selina

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Thu May 18 16:45:38 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Thu 18 May 2006 - 18:10:11 EST.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.