Re: [R] make error for R-2.3.0

From: Marc Schwartz (via MN) <mschwartz_at_mn.rr.com>
Date: Sat 20 May 2006 - 06:02:47 EST

On Fri, 2006-05-19 at 15:37 -0400, Randall C Johnson [Contr.] wrote:
> Hello,
> I'm trying to install R on a linux machine running Red Hat 8. I ran
>
> ./configure
> make
>
> and get the following error. I've installed several versions of R (2.2.1
> most recently) on this machine and haven't had any problems until now. I
> wondered if the outdated compiler (gcc version 3.2) was the problem and
> attempted to install my own, more recent version. I tried gcc versions 4.1.0
> and 3.4.6, but still have problems. The output below is using gcc 3.4.6 (my
> best attempt, but still ending with the same error as gcc 3.2). Any pointers
> would be appreciated.
>
> Best,
> Randy

<SNIP of sock.h related errors>

Randy,

This looks like the same issue that was reported on r-devel back at the end of April for RH 9.

Download the latest r-patched tarball and you should be OK. Prof. Ripley made some changes to sock.h that should get around these issues. Unfortunately, they were not reported until after the release of 2.3.0.

Download from here:

  ftp://ftp.stat.math.ethz.ch/Software/R/R-patched.tar.gz

It might be time to consider updating your system, since RH 8.0 is not even supported by the Fedora Legacy folks any longer. That means no functional or security updates.

Best regards,

Marc Schwartz



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sat May 20 06:11:09 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Sat 20 May 2006 - 08:10:15 EST.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.