Re: [R] Rpad Server Installation on Windows XP

From: roger bos <roger.bos_at_gmail.com>
Date: Sat 08 Jul 2006 - 03:45:09 EST

Claire,

I know you emailed me a question earlier and I just haven't gotten around to answering it. For both perl and rgui.exe (and rterm.exe) your path needs to state the location of these files. (I am not sure about this, but after you change the path you may even need to reboot for the change to be applied). Goto the dos prompt at C: and type in 'perl' and 'rterm' to make sure both are recognized.

I don't really know what makefile does, but my understanding is that it just copies the files and you can do that yourself. Once you do that, your 'server' folder on the rapd server will have some .pl files. An example of the R_process.pl file is below. I don't know why there is a #! in front of the path on the first line, but make sure that path points to the location of your perl install. Your perl istall is likely different from the default in the .pl files.

Once you have verified those two items, work through the troubleshooting portion of the rpad install notes and let us know which steps are working and which are not. As you can tell, I am no expert myself. I was very happy once I got it to work. Fortunately, it has worked like a charm ever since. I am just hoping I never have to do it again!! lol.

#!c:/perl/bin/perl.exe

# The following line is a test script to see if it works. #
http://localhost/Rpad/server/R_process.pl?&ID=ddNTlmHSvWZF&command=R_commands&R_commands=print('hello' )
use Statistics::Rpad ;
use strict ;
use CGI qw/:standard send_http_header/;
use Cwd ;
use utf8; # the decoding stuff is from spell-check-logic.cgi in the htmlarea spellcheck plugin
use Encode;

On 7/7/06, Minjeong Ahn <ahnmj@mit.edu> wrote:
>
>
> Hello,
> I have a question about Rpad Server Installation on Windows XP.
> Here is a guide
> http://www.rpad.org/Rpad/ServerNotes.html
> and I have been reading this more than ten times to figure this out, but
> still having trouble executing a Rpad website properly.
>
> Problem: for example, if I go to http://loclhost/Rpad/example1.rpad,
> I can see the whole website with the page loading sign staying on my
> screen (like forever)
> but if I push "calculate" button noting happens and the "page loading"
> sign goes away.
>
> Here, I think I have completed all steps needed,
> but I think I got something wrong with "Install the Statistice-
> R_perl_interface that come with Rpad in the serverversion directory."
> part.
>
> My Question: When I try installing serverversion files, I used
> -perl makefile.pl
> -nmake
> -nmake install
>
> in C:/Perl/bin directory. But I think the directory of perl might be
> some problem. I asked somebody out a week ago and he said I have to
> install perl on my path. Actually I don't quite know which directory
> he is talking about. I'm using xampp advanced version, so I should have
> perl installed and also I have active perl installed on my computer
> (c:/perl) What am I getting wrong?
>
> Question2: Do I have to install rterm too? If so, where?
>
> Any of your advice will be very appreciated.
> Thank you for your reading and have a great day everybody!
>
> best,
> Claire Ahn
> MIT
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide!
> http://www.R-project.org/posting-guide.html
>

        [[alternative HTML version deleted]]



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sat Jul 08 03:49:47 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Sat 08 Jul 2006 - 06:15:32 EST.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.