[R] Error install rgl package on linux

From: Muhammad Subianto <msubianto_at_gmail.com>
Date: Wed 12 Jul 2006 - 23:28:43 EST


Dear all,

I tried to install rgl package on my linux machine fc5, I got an error. Here I run R as user,
$ R

> options(repos=c(CRAN="http://cran.at.r-project.org/"))
> install.packages("rgl", lib="/home/subianto/local/lib/R/library/site-packages", dependencies=TRUE)
trying URL 'http://cran.at.r-project.org/src/contrib/rgl_0.67-2.tar.gz' Content type 'application/x-tar' length 567592 bytes opened URL



downloaded 554Kb

<snip>

Disposable.hpp:13: warning: 'struct IDisposeListener' has virtual functions but non-virtual destructor
gui.hpp:56: warning: 'class gui::WindowImpl' has virtual functions but non-virtual destructor
gui.hpp:90: warning: 'class gui::GUIFactory' has virtual functions but non-virtual destructor
g++ -shared -L/usr/local/lib -o rgl.so api.o Background.o BBoxDeco.o Color.o device.o devicemanager.o Disposable.o FaceSet.o fps.o geom.o gl2ps.o glgui.o gui.o Light.o LineSet.o LineStripSet.o Material.o math.o osxgui.o osxlib.o par3d.o pixmap.o PointSet.o PrimitiveSet.o QuadSet.o RenderContext.o render.o rglview.o scene.o select.o Shape.o SphereMesh.o SphereSet.o SpriteSet.o String.o Surface.o TextSet.o Texture.o TriangleSet.o types.o Viewpoint.o win32gui.o win32lib.o x11gui.o x11lib.o -L -lX11 -lXext -lGL -lGLU -L/usr/lib -lpng12 -L/usr/lib/R/lib -lR
/usr/bin/ld: cannot find -lXext
collect2: ld returned 1 exit status
make: *** [rgl.so] Error 1
chmod: cannot access
`/home/subianto/local/lib/R/library/site-packages/rgl/libs/*': No such file or directory
ERROR: compilation failed for package 'rgl' ** Removing '/home/subianto/local/lib/R/library/site-packages/rgl'

The downloaded packages are in

        /tmp/RtmpH3o1qG/downloaded_packages Warning messages:
1: installation of package 'rgl' had non-zero exit status in: install.packages("rgl", lib =
"/home/subianto/local/lib/R/library/site-packages", 2: cannot create HTML package index in: tools:::unix.packages.html(.Library) >

I think the error about missing devel-libraries on my fc5 but I do not know which libraries are. I apologize for my poor linux knowledge and expertise. Thank you very much.

Best, Muhammad Subianto

> version

               _
platform       i686-redhat-linux-gnu
arch           i686
os             linux-gnu
system         i686, linux-gnu
status
major          2
minor          3.1
year           2006
month          06
day            01
svn rev        38247
language       R

version.string Version 2.3.1 (2006-06-01) >

$ uname -r
2.6.17-1.2145_FC5



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Thu Jul 13 00:47:53 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Thu 13 Jul 2006 - 02:18:14 EST.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.