Re: [R] odesolve loading problem

From: <Setzer.Woodrow_at_epamail.epa.gov>
Date: Thu 27 Jul 2006 - 02:36:15 EST


Hi Ariel,
The problem is that I specified the wrong dependency in the DEPENDS field of the DESCRIPTION file of the package: I specified R version of at least 2.2.1, but that should have been 2.3.1. You have two choices -- upgrade your R to 2.3.1, or install odesolve 0.5.13. I will send an updated version of the package to CRAN, with a note to the CRAN maintainers about the problem, but that won't help you if you need to use R version 2.2.1. There is an archive of older R packages on CRAN, linked to at the bottom of the "Contributed Packages" page on CRAN. Please accept my apology for the inconvenience -- I rushed through a change requested by a user, and did not take time to fully appreciate the consequences.
Woody

R. Woodrow Setzer, Ph. D.
National Center for Computational Toxicology US Environmental Protection Agency
Mail Drop B205-01/US EPA/RTP, NC 27711
Ph: (919) 541-0128 Fax: (919) 541-1194

                                                                        
             Ariel                                                      
             Chernomoretz                                               
             <ariel@df.uba.ar                                        To 
             >                        r-help@stat.math.ethz.ch          
             Sent by:                                                cc 
             r-help-bounces@s                                           
             tat.math.ethz.ch                                   Subject 
                                      [R] odesolve loading problem      
                                                                        
             07/28/2006 01:30                                           
             AM                                                         
                                                                        
                                                                        
                                                                        




Hi,
I get the following error message when loading the package odesolve ( R 2.2.1 - odesolve 0.5.14 - AMD64 - Linux Fedora Core 4 ) :

> library(odesolve)

Error in library.dynam(lib,package,package.lib) :

       shared library 'TRUE' not found
Error: package/namespace load failed for 'odesolve'

Any help would be greatly appreciated

Ariel./



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide
http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code.

R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Thu Jul 27 02:43:31 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Thu 27 Jul 2006 - 04:18:59 EST.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.