[R] Sweave error in example code

From: LL <Lbrannma_at_yahoo.com>
Date: Tue 01 Aug 2006 - 03:35:46 EST


Hi.. I am running R version 2.3.1 on a Windows XP machine with the latest Miktex 2.5 installed. I get no errors from R when running the Sweave example,

testfile <- system.file("Sweave", "Sweave-test-1.Rnw", package = "utils")

However, when I tex the resulting .tex file (after installing a4.sty) I get the error below.

This is pdfeTeX, Version 3.141592-1.30.6-2.2 (MiKTeX 2.5 RC 1) entering extended mode
(Sweave-test-1.tex
LaTeX2e <2005/12/01>
Babel <v3.8g> and hyphenation patterns for english, dumylang, nohyphenation, ge rman, ngerman, french, loaded.
("C:\Program Files\MiKTeX 2.5\tex\latex\base\article.cls"
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
("C:\Program Files\MiKTeX 2.5\tex\latex\base\size10.clo"))
("C:\Program Files\MiKTeX 2.5\tex\latex\ltxmisc\a4wide.sty"
("C:\Program Files\MiKTeX 2.5\tex\latex\ntgclass\a4.sty"))
! Missing \endcsname inserted.
<to be read again>

                   \protect 
l.11 \begin
           {document}
? 
	[[alternative HTML version deleted]]

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Tue Aug 01 03:40:49 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Tue 01 Aug 2006 - 04:19:51 EST.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.