Re: [Rd] minor build problem

From: Cyrus Harmon <ch-r-devel_at_bobobeach.com>
Date: Fri 14 Apr 2006 - 22:12:24 GMT

Perhaps I'm doing something wrong here, but I'm still seeing the:

help2man: can't get `--version' info from ../bin/R

error message here. and the make; make; make install workaround doesn't seem to be working for me. I don't know if this is due to incompatible versions of perl, but I've tried 5.8.6 and 5.8.8 to no avail.

This is on MacOS X 10.4.6/PPC from the latest SVN sources (37777), building in a separate directory.

Thanks,

Cyrus

On Jan 7, 2006, at 10:53 AM, Prof Brian Ripley wrote:

> We know: this is due to a change in where the version is stored
> that someone did not check the consequences of. It will be fixed
> shortly (I am testing a fix right now). Meanwhile,
>
> make; make; make install
>
> works.
>
> On Sat, 7 Jan 2006, Cyrus Harmon wrote:
>
>> I'm trying to build from the latest SVN sources on Mac OS X 10.4.3
>> and I seem to be having a problem making the documentation.
>>
>> When I do make install, i get the following:
>>
>> (sly@gigondas):~/src/R/r-devel/build-f95$ make install
>> make[1]: Nothing to be done for `front-matter'.
>> SVN-REVISION is unchanged
>> make[1]: Nothing to be done for `install'.
>> make[1]: Nothing to be done for `install'.
>> installing doc ...
>> /sw/bin/install: cannot stat `R.1': No such file or directory
>> make[1]: *** [install-man] Error 1
>> make: *** [install] Error 1
>>
>> which is due to the fact that R.1 doesn't exist. When I try to
>> make R.
>> 1 by going into docs and doing make svnonly, I get:
>>
>> (sly@gigondas):~/src/R/r-devel/build-f95/doc$ make svnonly
>> make[1]: `R.fe' is up to date.
>> help2man: can't get `--version' info from ../src/scripts/R.fe
>>
>>
>> When I try to run help2man manually I get:
>>
>> (sly@gigondas):~/src/R/r-devel/build-f95/doc$ perl ../../R/tools/
>> help2man.pl --include=../../R/doc/R.aux --no-info --output=R.1 --
>> name="a language for data analysis and graphics" ../src/scripts/R.fe
>> help2man: can't get `--version' info from ../src/scripts/R.fe
>>
>>
>> If I try to get the version info from ../src/scripts/R.fe directly, I
>> get:
>>
>> (sly@gigondas):~/src/R/r-devel/build-f95/doc$ ../src/scripts/R.fe --
>> version
>> Version 2.3.0 Under development (unstable) (2006-01-07 r37011)
>> Copyright (C) 2006 R Development Core Team
>>
>> R is free software and comes with ABSOLUTELY NO WARRANTY.
>> You are welcome to redistribute it under the terms of the
>> GNU General Public License. For more information about
>> these matters, see http://www.gnu.org/copyleft/gpl.html.
>>
>>
>> So that seems to work. There must be some problem parsing this
>> output. Does have an idea why help2man is failing here?
>>
>> Thanks,
>>
>> Cyrus
>>
>> ______________________________________________
>> R-devel@r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-devel
>>
>>
>
> --
> Brian D. Ripley, ripley@stats.ox.ac.uk
> Professor of Applied Statistics, http://www.stats.ox.ac.uk/~ripley/
> University of Oxford, Tel: +44 1865 272861 (self)
> 1 South Parks Road, +44 1865 272866 (PA)
> Oxford OX1 3TG, UK Fax: +44 1865 272595



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Sat Apr 15 08:42:41 2006

This archive was generated by hypermail 2.1.8 : Sat 15 Apr 2006 - 00:17:09 GMT