Re: [R] Problems with Rscript executable.

From: Gregg Phillips <Gregory.M.Phillips_at_noaa.gov>
Date: Mon, 28 Apr 2008 12:23:23 -0600

Yes,

Re-running make install at the src/unix level seems to have fixed it. I originally ran make install at the top level after running ./configure --prefix=/usr/local/r-2.7.0.

Thank You for your assistance,

Gregg.

Prof Brian Ripley wrote:
>> I have recently built R version 2.7.0 on a CentOS release 4.6, 64-bit
>> system using the following command:
>
>> ./configure --prefix=/usr/local/r-2.7.0
>
>> Everything built fine and works properly except for Rscript which is
>> looking for files in the original build directory instead of the
>> specified install directory. Did I forget to add a flag or is this a
>> bug?
>
> How did you install? If you do
>
> cd src/unix
> make install
>
> you should see Rscript being remade with the destination path included.
> E.g. I see
>
> auk% make install
> gcc -std=gnu99 -I. -I../../src/include -I../../src/include
> -I/usr/local/include -DHAVE_CONFIG_H -g -O2
> -DR_HOME='"/usr/local/lib64/R"' -o Rscript \
> ./Rscript.c
>
> I've seen problems with parallel makes, but running this again should
> solve those.
>



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Mon 28 Apr 2008 - 19:28:25 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 28 Apr 2008 - 19:30:33 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive