[Rd] options(width=100) ignored on start-up: bug or feature?

From: Liviu Andronic <landronimirc_at_gmail.com>
Date: Mon, 07 Dec 2009 07:58:23 +0000


Dear developers
I've tried this a couple of days ago on r-help, unfortunately with no feedback. Could you please take a look and confirm whether it's a bug, feature, or bad eye-sight when reading Help:

 Is it normal that R ignores options("width"=100) at start-up? Although  liviu_at_debian-liv:~$ cat /usr/lib/R/etc/Rprofile.site | grep width  options(width = 100)

 , R will start with
 [Previously saved workspace restored]

 > options()$width
 [1] 80

 Am I doing something wrong?
 Liviu

 > sessionInfo()
 R version 2.10.0 (2009-10-26)
 x86_64-pc-linux-gnu

 locale:
[1] LC_CTYPE=en_GB.UTF-8 LC_NUMERIC=C
[3] LC_TIME=en_GB.UTF-8 LC_COLLATE=en_GB.UTF-8
[5] LC_MONETARY=C LC_MESSAGES=en_GB.UTF-8
[7] LC_PAPER=en_GB.UTF-8 LC_NAME=C
[9] LC_ADDRESS=C LC_TELEPHONE=C
 [11] LC_MEASUREMENT=en_GB.UTF-8 LC_IDENTIFICATION=C

 attached base packages:
[1] datasets grid splines graphics stats utils grDevices
[8] tcltk methods base

 other attached packages:
[1] fortunes_1.3-6 RcmdrPlugin.HH_1.1-25 HH_2.1-32
[4] leaps_2.9 multcomp_1.1-2 mvtnorm_0.9-8
[7] lattice_0.17-26 RcmdrPlugin.sos_0.1-0 RcmdrPlugin.Export_0.3-0

 [10] Hmisc_3.7-0              survival_2.35-7          xtable_1.5-6
 [13] Rcmdr_1.5-4              car_1.2-16               relimp_1.0-1
 [16] sos_1.1-7                brew_1.0-3               hints_1.0.1-1

 loaded via a namespace (and not attached):  [1] cluster_1.12.1



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Mon 07 Dec 2009 - 08:04:36 GMT

This archive was generated by hypermail 2.2.0 : Mon 21 Dec 2009 - 12:51:12 GMT